Creating a wearable, instant transaction failed on Matic

Wearable is “ready to mint” first one, GIF looks good, “Ok” but when as soon as I click Mint it shows “transaction Failed”
Thank you

I can’t help without more info;

  • What is the collection?
  • Do you own the collection?
1 Like

Thank you for your reply,
Yes I own it, it is the collection number 442,
tried using metamask on various browsers,

oh and I believe I might have had created more than one collection at first (transaction issues) but I deleted the others and it displays one collection everywhere now. I also own a parcel.

Not sure it will help but here are the console errors
inpage.js:1
MetaMask - RPC Error: Internal JSON-RPC error.
Objectcode: -32603data: code: 3data: “0x08c379a0000000000000000000000000000000000000000000000000000000000000002000000000000000000000000000000000000000000000000000000000000000204f776e61626c653a2063616c6c6572206973206e6f7420746865206f776e6572”
message: “execution reverted: Ownable: caller is not the owner”[[Prototype]]: Objectmessage: “Internal JSON-RPC error.”[[Prototype]]: Objectconstructor: ƒ Object()hasOwnProperty: ƒ hasOwnProperty()isPrototypeOf: ƒ isPrototypeOf()propertyIsEnumerable: ƒ propertyIsEnumerable()toLocaleString: ƒ toLocaleString()toString: ƒ toString()valueOf: ƒ valueOf()defineGetter: ƒ defineGetter()defineSetter: ƒ defineSetter()lookupGetter: ƒ lookupGetter()lookupSetter: ƒ lookupSetter()proto: (…)get proto: ƒ proto()set proto: ƒ proto()
(anonymous) @ inpage.js:1
web-8.16.1.js:2 error: /*Repeat

Here is the smart contract in admin
0xB45f6A85BFdE25F25CC819fF0eb7468E6BEbBf9F

thank you

Ok, so I’m investigating this.

The wallet you’re using right now is 0xbac89cb9befe09c226bb7003869642b7a0550988
and the contract says the owner is 0x3cf346ed45bb72c21c925de3db15d5c87ad2129a

and I can confirm the first wallet owns the collection on our side.

I also can confirm you made a lot of collections.

According to the blockchain, and from what I can see, you made a few collections with different owner addresses and decided to keep one as yours. The problem is that now the contract on the chain is collection_id 446 while the collection on CV is ID 442. Not only that, you’ve been trying to mint on a contract that’s got a different owner.

When you made the collection, did you ever face the Maintenance page of the collection?

I overrode the contract address on your collection to be the 442 one.
If you don’t like that contract I recommend recreating a collection

cheers

Thanks!
when creating it I got multiple failed tx, it kept telling me the contract wasn’t deployed, I tried restarting a couple time (443,444). I changed my RPC, and the tx passed, but I hadn’t seen the ownership condition for minting, so I think I validated each collection thinking there was still a bug.
I deleted the extra collections and bought a parcel. Then could access the collection properly but couldn’t mint.
I advise people who encounter issues to polygon to go to Network | Polygon Technology | Documentation and change their RPC to another one.
Sorry for the hassle it works perfectly now! @Fayelure

1 Like