Audio stop and pause methods are not working

The stop method of audio features… stopped working. Since the last release, it seems. I’ve just realized the method is not documented (not sure if that was always the case), but it did use to work, and is not throwing any error or warning message on the console log when called. The pause method (documented) is not working either. The play method is working as expected.

Tried in a parcel and in a space.

Space Id: df0cde2a-b2c3-4e12-a30b-5c95d0d53791
Script: https://untrusted.cryptovoxels.com/grid/spaces/df0cde2a-b2c3-4e12-a30b-5c95d0d53791/scripts.js

System Details

  • browser: Chrome, Firefox and Safari.
  • browser version: latest
  • operating system: MacOS
  • how are you using cryptovoxels
    • [x] desktop web
    • [ ] mobile web
    • [ ] native VR app

Ok thanks we’ll take a look! :mute:

Because this is feature-specific, these methods are found on the feature page:

At the bottom of the page you can find feature specific properties or methods.

Also, the .pause() function worked fine for me, but .stop was totally busted indeed. I have fixed it and it should be out monday morning (NZT)

Thanks!

I tried again in my space and audio pause method is not working.

Regarding documentation, audio feature doc page only lists play and pause methods.

https://wiki.cryptovoxels.com/features/audio

image

1 Like

RIght ok I see what’s going on; I misunderstood you, I thought you were talking about videos.

Turns out the Audio feature never had a pause function but did have a Stop function.

I fixed it and will push the edit today with the fix for Stop()

1 Like

Also that space’s example was amazing thank you so much for doing that

It’s working! Thanks to you for your prompt response.